Ad Radar
Car Craft
Click here to find out more!

GMC 2001 Jimmy Rebuilt 4.3L Oil Problem

  
Car Craft
Item Posts    Sort Order

GMC 2001 Jimmy Rebuilt 4.3L Oil Problem

 
NEB100 NEB100
New User | Posts: 4 | Joined: 06/13
Posted: 06/04/13
11:00 AM

I just finished rebuilding the engine and have primed the oil system, but am not getting any oil to the #6 exhaust rocker arm (rear most rocker arm on right side-pax side. I have taken the lower intake manifold off and checked everything to include changing the lifter with another one - they are all new. The lifters were soaked in oil before being installed . I have an oil gage installed and show 40 psi.
I have also been rotating the engine over while priming .

I have removed the intake manifold again and taken the lifter out, Checked the oil holes on each side of the lifter and into the ditributor hole, All clear, Any help is appreciated  

waynep712222 waynep712222
User | Posts: 103 | Joined: 03/13
Posted: 06/05/13
05:38 AM

the engine needs to run usually to finally bleed all the air out of the lifters..

usually i install lifters without presoaking them.. but i do use assembly lube on the foot..

roller lifters probably do need the roller end soaked..  but most of it will probably drip out..

that engine should be equipped with hydraulic roller lifters..  and a roller camshaft.. is it???

Hydrauliclifterinterals Zps81c88d7a


since thats a VORTEC motor.. if it still is..  do you know that the distributer has to be installed correctly... and afterwords.. it has to have the crank / cam sensor offset checked with an advanced  scan tool .. then adjusted as close to ZERO offset as possible..   generic scan tools usually don't have this ability..  

NEB100 NEB100
New User | Posts: 4 | Joined: 06/13
Posted: 06/05/13
08:45 PM

Appreciate your help!  So if I have checked everything as I stated earlier and getting good oil pressure and oil to all the other lifters/rockers then I should be okay to run it for a short while then take off the valve covers and check to make sure that rocker is getting oil?

Yes they are new hydraulic roller lifters and original camshaft.

Appreciate your help on the distributor - I will check that it is installed correctly and check the sensor.  

Thanks again!!  

waynep712222 waynep712222
User | Posts: 103 | Joined: 03/13
Posted: 06/06/13
05:55 AM

instructions on setting the vortec distributer...

put some lube into the rocker arm pivots.. and the valve tip.. you should be able to seal these engines and get them to start..

Vortecdistributerinstal



page 2.

Vortecdistributerinstal

you can see the 8 in this image.. the 6 is unmarked on this image.. but its at the other arrow shaped thing at almost 3 o clock in this image..

Vortecdistributeralignm  

NEB100 NEB100
New User | Posts: 4 | Joined: 06/13
Posted: 06/06/13
08:59 AM

Again thanks - appreciate your providing so much info.
I'm on the road right now and not be home till mid next week.  As soon as I get home and have a chance to get all back together and run engine - I will post my results back here.  

NEB100 NEB100
New User | Posts: 4 | Joined: 06/13
Posted: 07/12/13
04:05 PM

I finished putting the engine back together - primed oil system - started right up and no problems.  Got about 500 miles on it and no problems.  Appreciate your help